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About this manual

Purpose of this manual

This manual tells you how to install, configure and use the PortDirector software. 

Who this manual is for

This manual is aimed at PC users who want to display or configure com ports on their 
systems (provided by Perle connectivity products). This manual requires a working 
knowledge of using personal computers and associated operating systems.

Note 
For details of the operating system and hardware needed to run the 
PortDirector software, see System requirements on page 20.
PortDirector User guide 
Purpose of this manual
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Using this on-line manual

The following is a brief guide to using this manual on-line.

Document navigation

This manual features document navigation hypertext buttons in the header area as shown in 
the next picture;

Hypertext jumps

You can also navigate around this manual by clicking on any cross reference or text in blue 
for example, Hypertext jumps. 

Jump to Using this on-line manual

Jump to Index

Jump to Quick Reference 

Jump to previous location 

Jump to front of current chapter

Jump to Contents

Jump to Fast contents

Note
The Fast Contents, Contents and Index entries are all hypertext 
jumps into this manual.
PortDirector User guide 
Using this on-line manual
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Chapter 1  Introduction

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want an introduction to the PortDirector software.

This chapter provides an introduction to the PortDirector software (page 16) information on 
how to use the product (page 17) and lists related hardware documentation (page 18).

This chapter includes the following sections;

• About the PortDirector software on page 16

• How to use the PortDirector software on page 17

• Related hardware documentation on page 18.
PortDirector User guide 
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About the PortDirector software

The PortDirector is a software tool which allows you to display and configure the parameters 
of serial ports connected to your PC system. In addition, you can use PortDirector to 
configure host cards and device concentrators attached to your system and to perform 
various basic diagnostic functions on the connected devices.

You use the PortDirector software because you want an application which is not device 
specific or you are working with a system which includes Perle connectivity products.

The PortDirector software allows you display a topological view of the PC ports and 
peripherals connected to the system and allows you to control the ports and devices for the 
Perle SX, I/O8+, FAST, SPEED, PCI-RAS, RIO, UltraPort and Ultraport SI products.

PortDirector supports the above Perle products as well as third party products which it treats 
as generic com ports.

The Windows 2000 version of PortDirector includes device mapping facilities which allow you 
to display a visual map of the actual connections between the hardware devices in a system. 
Using the Device Map facility you can manage networks components in remote locations and 
perform a variety of network management tasks. See Displaying a map of system 
connections on page 39. This facility is especially useful in managing network components 
spread over a wide area.

PC system

Host 
cards

PortDirector

Device concentrators 
with Serial ports

Configure 
and display
PortDirector User guide 
About the PortDirector software
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How to use the PortDirector software

The general procedure for using the PortDirector software is as follows;

1. Install the PortDirector software onto your PC system. See General installation 
procedure on page 21.

2. Start the PortDirector software on your system. See Starting PortDirector on page 30.
3. If required, display the device drivers, host cards, device concentrators and com ports 

present in your system. See Displaying the system hierarchy on page 33 and 
Displaying details of system components on page 37.

4. If required, add or delete any host cards from your system as needed. See Adding host 
cards on page 51 and Deleting host cards on page 55.

5. If required, re-scan your system for any devices which are present but not active. See Re-
scanning the system on page 57.

6. If required, configure the com ports on your system. See Working with com ports on 
page 59

7. Exit from the PortDirector software on your system. See Exiting PortDirector on 
page 31.

8. If required, remove the PortDirector software from your system. See Removing 
PortDirector from your system on page 27.

Note 
For details of the operating system and hardware needed to run the 
PortDirector software, see System requirements on page 20.

Hint
For Windows 2000 installations you can also use Device map to view and 
manage your system. See Displaying a map of system connections on 
page 39.
PortDirector User guide 
How to use the PortDirector software
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Related hardware documentation

For information about the hardware products used with this software, see the following 
product manuals;

• SX Quick start guide

• SX Installation Guide

• SX Configuration Guide

• SX release notes

• I/O8+ user guide

• SPEED user guide.

• Ultraport Serial Adapters User Guide
PortDirector User guide 
Related hardware documentation
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Chapter 2  Installing and removing PortDirector

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want to install the PortDirector application onto your 
system.

This chapter tells you how to install PortDirector on your system. You can do this either from 
CDROM (page 24) or by down loading from the Perle web site (page 25). Also included are 
the system requirements to run PortDirector (page 20) and the procedure for removing the 
PortDirector software from your system (page 27).

This chapter includes the following sections;

• System requirements on page 20

• General installation procedure on page 21

• Installing PortDirector from CDROM on page 24

• Down loading PortDirector from the Perle web site on page 25

• Updating an existing device driver on page 26

• Removing PortDirector from your system on page 27.
PortDirector User guide 
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System requirements

In order to run the PortDirector software you need a system which conforms to the following 
requirements:.

In the event of any problems, please contact your system administrator for assistance.

Item Description
Platform PC
Operating system Windows NT 4, or Windows 2000.
Memory 32 Mb RAM
Disk space to store 5Mb minimum
PortDirector User guide 
System requirements
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General installation procedure

The general procedure for installing the PortDirector software under either the Windows NT 
or Windows 2000 operating systems is as follows;

Loading the 
software

1. Load the PortDirector software onto your system either from CDROM or by down loading 
from the Perle web site using the procedures described in one of the following:

• Installing PortDirector from CDROM on page 24
• Down loading PortDirector from the Perle web site on page 25.

Choosing the 
destination folder

The Choose Destination Location window and a popup message window are now 
displayed as shown in the next pictures.

Note
PortDirector is available in separate versions for Windows NT and Windows 2000. The 
installation procedure for the different versions is virtually identical. Any differences are 
highlighted in the procedure. 
The Windows 2000 version does not include device drivers. You need to 
install device drivers independently of this application.

Caution
Do not install version 1.04 or earlier of PortDirector under 
Windows 2000 as this may cause problems with your existing 
device driver installation.

Note
If you try to install the Windows NT version of PortDirector on a Windows 2000 
system, a message is now displayed informing you that you are installing the 
wrong version and no further installation will be permitted by the software.

If this happens repeat step 1. of this procedure using the correct version of 
PortDirector.
PortDirector User guide 
General installation procedure
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2. In the pop-up message window, click on the OK button to close the window.
3. If required, in the Choose Destination Location window, click the Browse button to 

change the destination folder.

A file browser is now displayed.

4.  In the browser, choose the new location you want and close the browser.

 The destination folder is now updated accordingly.

5. In the Choose Destination Location window, click on the Next button.
The Select Program Folder window is now displayed showing the default folder as shown 
in the next picture.
PortDirector User guide 
General installation procedure

Page 22

Chapter 2 Installing and removing PortDirector



 
6. If required, in the Select Program Folder window, select a new folder by entering the file 

and path names into the Program Folders field. Alternatively, in the same window, click 
on an entry in the Existing Folders field. 

7. In the Select Program Folder window, click on the Next button.

The PortDirector application is now copied onto your system thereby completing the 
installation process.

You can now use the PortDirector application to set up your system. See page 15 for further 
details.

Note
Following installation of PortDirector under either Windows NT and 
Windows 2000 we recommend re-application of the current service 
pack. See your Windows user documentation for and on-line help 
further details.
PortDirector User guide 
General installation procedure
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Installing PortDirector from CDROM

To load PortDirector from CDROM proceed as follows:

1. Load the CDROM into your PC.

2. In the Windows desktop on your PC, click on the Start button then select 
Programs> Windows Explorer. 
The Explorer window is now displayed.

3. In the left hand view of the Explorer window, select the CD icon.

The right hand view of the Explorer window is now updated to show the contents of the 
CD.

4. In the right hand view of the Explorer window, select the \Drivers\PortDirector directory 
and click on the Set up application icon.

The PortDirector Setup Application and Choose Destination Location windows now 
appear.

5. Now follow the steps described in Choosing the destination folder in the General 
installation procedure on page 21 to complete the installation process.
PortDirector User guide 
Installing PortDirector from CDROM

Page 24

Chapter 2 Installing and removing PortDirector



Down loading PortDirector from the Perle web site

You can install the PortDirector software from the Perle web site. To do this proceed as 
follows;

1. On your PC, start the Internet browser you want to use (for example, Netscape).

2. Within your Internet browser window, select the software directory using the following 
URL;
http://www.perle.com/downloads/index.html 

3. Change to the directory for the operating system you want as shown in the next table.

The software directory is now displayed.

4. Download the files in this directory to a suitable location on your PC for example, c:\temp.

5. In the Windows desktop on your PC, click on the Start button then select 
Programs > Windows Explorer.
The Explorer window is now displayed.

6. In the Explorer window, display the location of the PortDirector zip file you have 
downloaded.

7. Using the software tool of your choice, (for example, Win Zip) unzip the file.

The PortDirector software directory is now displayed.

8. In the right hand view of the Explorer window, select the PortDirector directory and click 
on the Set up application icon.

The PortDirector Setup Application and Choose Destination Location windows now 
appear.

9. Now follow the steps described in Choosing the destination folder of the General 
installation procedure on page 21 to complete the installation process.

Note
In the event of any problems contact your System Administrator or 
Internet Service provider for assistance.

Operating system Directory
Windows NT winnt
Windows 2000 w2k
PortDirector User guide 
Down loading PortDirector from the Perle web site
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Updating an existing device driver

Normally you would not need to update an existing driver. PortDirector is usually distributed 
as a complete package. This procedure is only used in special circumstances.

The PortDirector software allows you to update an existing device driver. For example, a 
Perle IO8+ Serial device driver. You update device drivers when you want to use a new 
version of an existing device driver (for example, new release containing product 
enhancements). The files you update have the.sys extension for example, for IO8 it would be 
IO8.sys and so on. 

To update a device driver proceed as follows;

1. In the PortDirector window, click on the icon for the device driver you want.

2. In the PortDirector window, click on the right mouse button and select the Update device 
menu option (available in both left and right hand view). Alternatively, in the PortDirector 
window click on the Update device button.
A popup window now appears asking you to confirm the update.

3. In the pop-up, click on Yes to confirm your selection.

A browser is now displayed.

4. In the browser, locate and select the new version of the device driver you are updating 
and click on Open.

The new device driver is now installed.

Note
You can only update an existing device driver if that device and all its 
ports are inactive.
PortDirector User guide 
Updating an existing device driver
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Removing PortDirector from your system

To remove (uninstall) PortDirector from your system proceed as follows;

1. In the Windows desktop on your PC, click on the Start button and select the Settings > 
Control Panel menu option. 

The Control Panel window is now displayed.

2. In the Control Panel window, double click on the Add/Remove Programs icon.

The Add/Remove Programs Properties window is now displayed.

3. In the Add/Remove Programs Properties window, click on the tab to display the Install/
Uninstall page (shown in the next picture).
PortDirector User guide 
Removing PortDirector from your system
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4. In the Install/Uninstall page, select PortDirector as the application you want to remove 
and then click on the Add/Remove button.

A pop-up appears asking you to confirm the deletion

5. In the pop-up, click on Yes to confirm the removal of the PortDirector software from your 
system.

A message is now displayed while the software is removed.

The PortDirector is now removed from your system with no further prompts.
PortDirector User guide 
Removing PortDirector from your system
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Chapter 3  Starting and exiting PortDirector

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want to start or exit the PortDirector software.

This chapter tells you the procedure for starting the PortDirector software from the Windows 
desktop and also how to exit from PortDirector from within the software. 

This chapter includes the following sections;

• Starting PortDirector on page 30

• Exiting PortDirector on page 31
PortDirector User guide 
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Starting PortDirector

To start the PortDirector software from the Windows start menu, proceed as follows;

1. In the Windows desktop on your PC, click on the Start button then select 
Programs > PortDirector. 

The PortDirector window is now displayed and you can start using the software (Windows 
NT opening screen shown).

Hint

You can also start PortDirector using a windows shortcut as 
follows:

1. In the Windows Desktop double click on the PortDirector 

shortcut icon  (See Windows user documentation).
PortDirector User guide 
Starting PortDirector

Page 30

Chapter 3 Starting and exiting PortDirector



Exiting PortDirector

To exit from the PortDirector software proceed as follows;

1. In the PortDirector menu, click on File > Exit.

The PortDirector software now closes.
PortDirector User guide 
Exiting PortDirector
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Chapter 4  Displaying your system

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want to display a map of the cards and devices on your 
system.

This chapter tells you how to use PortDirector to display a map of the device drivers, host 
cards, device concentrators and com ports present in your system. Also included are the 
options for displaying details of system components in the right hand view of the PortDirector 
window. 

This chapter includes the following sections;

• Displaying the system hierarchy on page 33

• Printing a copy of the system hierarchy on page 36

• Displaying details of system components on page 37

• Displaying a map of system connections on page 39
PortDirector User guide 
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Displaying the system hierarchy

PortDirector allows you to display a map showing full details of Perle products such as device 
drivers, host cards, device concentrators and com ports present in your system. In addition, 
you can also display the com ports of third party products.

You display a system hierarchy because you want to see a map of your entire system and 
identify individual items such as com ports or host cards. This makes its easier to decide 
which devices to configure and where they are in the system. This is especially useful when 
you have a large number of com ports.

For example, some host cards like the Perle I/O8+ or SPEED have connections for serial 
devices direct to the back of the host card where as other cards like the Perle SX and RIO 
have serial connections made to the device concentrators connected to the host card.

You display the components of your system by clicking on an Explorer style hierarchy tree in 
the left hand view of the PortDirector window, or by double clicking on an item in the right 
hand view of the same window.

To display the components of your system proceed as follows;

1. Start the PortDirector software using the procedures given on page 29.
The PortDirector window is now displayed in Topology view as shown in the next picture.

Note 
If you try and display a component which is not physically present in your PC then it 
will appear greyed out as shown in the next picture.

A typical example, is when an ISA card is no longer present in the system or does 
not have any Device concentrators attached.
PortDirector User guide 
Displaying the system hierarchy
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You can now display system components in the right hand view of the PortDirector 
window by clicking on icons in the explorer style hierarchy tree in the left hand view as 
shown in the next picture.

2. In the PortDirector window, display the system component you want by clicking on an icon 
in the Explorer style hierarchy tree in the left hand view. Alternatively, click on an icon you 
want in the right hand view. 

The icons and their corresponding devices are shown in the next table:

Note
The order in which com ports are displayed is the order in which they 
are physically present on the parent device.

Click on an icon to 
display a system 
component.

System 
component 
displayed in 
right hand 
view.
PortDirector User guide 
Displaying the system hierarchy
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To display... Click icon Example display
Device drivers

Host cards

Device 
concentrators

Com ports
Displayed in the 
order in which they 
are physically 
present on the 
parent device.
PortDirector User guide 
Displaying the system hierarchy
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Printing a copy of the system hierarchy

PortDirector allows you to print a copy of the complete system hierarchy. You can also 
preview the system hierarchy before printing. To print the system hierarchy proceed as 
follows;

1. In the PortDirector menu, click on File > Print Preview. Alternatively in the toolbar, click 
on the print preview icon.

A preview of the system hierarchy you are printing is now displayed as shown in the next 
picture.

2. If required, in the print preview display, click on the Print button to print the current 
hierarchy. Alternatively, in the PortDirector menu, click on File > Print.
The standard Windows print window is now displayed.

3. In the Print window, set the print parameters you want then press OK to confirm and print 
your selection.

4. If required, in the Preview display click on the Close button to close print preview.

Note 
PortDirector allows you to print the complete system hierarchy 
only.

Hint 
To setup the printer, in the In the PortDirector menu, click on File > Print 
Setup and use the resulting window to adjust printer settings. For further 
details, see the Windows user documentation.
PortDirector User guide 
Printing a copy of the system hierarchy
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Displaying details of system components

PortDirector allows you to display system components in the right hand view of the 
PortDirector window in a variety of ways. You do this by clicking on certain buttons in the tool 
bar area of the PortDirector window as shown in the next picture.

You can display items as large or small icons, display basic or detailed lists and show 
connector pinouts.To do this proceed as follows;

1. In the PortDirector window, display the system component you want by clicking on an icon 
in the Explorer style hierarchy tree in the left hand view. Alternatively, click on an icon you 
want in the right hand view (see also page 33).

2. In the PortDirector window, click on one of the tool bar icons or menu options shown in the 
next table to display the system component using the method you want.

Click here to display 
connector pinouts.

Click here to change 
right hand view display
PortDirector User guide 
Displaying details of system components

Page 37

Chapter 4 Displaying your system



 

To display... Menu option Tool bar Example display
Large icons View > Large Icons

Small icons View > Small Icons

List of icons View > List View

List including details View > Details View

Connector pinouts View > Pinouts
PortDirector User guide 
Displaying details of system components
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Displaying a map of system connections 

This section includes the following;
• Introduction to Device Map on page 40

• General procedure for displaying a device map on page 41

• Displaying a device map on page 42

• Displaying the identity of system components on page 44

• Adopting ports on page 45

• Rebooting an RTA on page 47

• Disconnecting system components on page 48

• Deleting system components and associated ports on page 49

Note
The facilities described in this section are only available when using 
PortDirector under Windows 2000.
PortDirector User guide 
Displaying a map of system connections
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Introduction to Device Map

PortDirector includes device mapping facilities which allow you to display a visual map of the 
actual connections between the hardware devices in a system. For example in a RIO system 
it can display which sockets on a given RTA are connected to which sockets on a given host 
card. The next picture shows a typical example.

Using the Device Map facility, you can manage network components in remote locations and 
perform a variety of network management tasks. See General procedure for displaying a 
device map on page 41. This facility is especially useful in managing network components 
spread over a wide area.

For colour key see 
page 43.
PortDirector User guide 
Displaying a map of system connections
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General procedure for displaying a device map

The general procedure for displaying a map of your system connections is as follows;

1. Install your system components and then display the current system in port director. See 
Displaying a device map on page 42.

2. Within PortDirector perform the management task you want with the system using one of 
the facilities listed in the next table

3. Make any physical changes to your system hardware. See your system user 
documentation for details.

Note
The facilities described in this section are only available when using 
PortDirector under Windows 2000.

Task Toolbar Menu option

To find 
further 
details ...

Displaying the identity of 
system components

Tasks > Device Map Tools > 
Identify

See page 44.

Adopting ports Tasks > Device Map Tools > Adopt See page 45.

Re-booting RTAs Tasks > Device Map Tools > 
Reboot

See page 47.

Disconnecting system 
components

Tasks > Device Map Tools > 
Zombie

See page 48.

Deleting system components 
and associated ports.

Tasks > Device Map Tools > Delete See page 49.
PortDirector User guide 
Displaying a map of system connections
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Displaying a device map 

To display a device map in PortDirector proceed as follows;
1. In the PortDirector window, click on the Device Map icon in the View toolbar as shown in 

the next picture.

PortDirector now displays a device map of the current system (colour key on page 43).

Click here to display 
a Device Map.
PortDirector User guide 
Displaying a map of system connections
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Key to device map colours

The colours used on the device map view in port drector are as shown in the next table;

Link type Colour
Standard link Lime green
Fibre optic (FOLK) link Blue
Long distance module (LDM) link Dark Cyan
Interlink Dark purple
PortDirector User guide 
Displaying a map of system connections
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Displaying the identity of system components

To display the identitiy of a device on a device map, proceed as follows;
1. In the PortDirector window, click on the Device Map icon in the View toolbar.

The device map is now displayed for the current system (see also Displaying a device 
map on page 42).

2. In the Device map, click on the device you want to identify to highlight it.

3. In the PortDirector menu, click on Tasks > Device Map Tools > Identify. Alternatively, in 
the toolbar click on the  icon.

The selected device identity is now displayed on the Device map along side the Device 
Icon.

Hint
To hide the identity of the devices displayed, proceed as follows;
• In the Device map, click on a blank area of the display.

The identities of all displayed devices is now hidden.
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Adopting ports

When you are installing a new RTA, PortDirector allows you to adopt the port names of RTAs 
no longer connected to the system (known as orphaned). To adopt port names in this way 
proceed as follows;

1. In the PortDirector window, click on the Device Map icon in the View toolbar.

The device map is now displayed for the current system (see also Displaying a device 
map on page 42).

2. Connect the new RTA to your system. See your user manual for details.

3. In the Device map, click on the device you want to adopt to highlight it.

4. In the PortDirector menu, click on Tasks > Device Map Tools > Adopt. Alternatively, in 
the toolbar click on the  icon.

The Port Adoption window is now displayed as shown in the next picture.

Note
You cannot adopt ports from an 8 port device onto a 16 port device.

Note
If you adopt ports from a 16 port device onto an 8 port device, the first 8 
ports are adopted and the remaining 8 ports discarded.
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5. In the Port Adoption window, click on the device whose ports you want to adopt to 
highlight it and then click on the Adopt Ports button.
The selected ports are now adopted. The original device from which you have adopted 
the ports is removed from the system.
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Rebooting an RTA

PortDirector allows you to re-boot any RTA displayed on the Device map without having to 
touch the actual unit. To re-boot an RTA in this way proceed as follows;
1. In the PortDirector window, click on the Device Map icon in the View toolbar.

The device map is now displayed for the current system (see also Displaying a device 
map on page 42).

2. In the Device map, click on the device you want to re-boot to highlight it.

3. In the PortDirector menu, click on Tasks > Device Map Tools > Reboot. Alternatively, in 
the toolbar click on the  icon.

The selected device is now re-booted.
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Disconnecting system components

PortDirector allows you to disconnect an RTA from the system without physically unplugging 
it. This process is known as zombieing. To disconnect an RTA in this way proceed as follows;
1. In the PortDirector window, click on the Device Map icon in the View toolbar.

The device map is now displayed for the current system (see also Displaying a device 
map on page 42). An example of a connected device is shown in the next picture.

2. In the Device map, click on the device you want to disconnect to highlight it.

3. In the PortDirector menu, click on Tasks > Device Map Tools > Zombie. Alternatively, in 
the toolbar click on the  icon.

The selected device is now disconnected and the appropriate LEDs on the device map 
display and on the real device are flashed. The links are now removed on the displayed 
device as shown in the next picture.
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Deleting system components and associated ports

PortDirector allows you to permanently delete an RTA and its associated ports from the 
system without physically unplugging it. To delete an RTA and its ports proceed as follows;
1. In the PortDirector window, click on the Device Map icon in the View toolbar.

The device map is now displayed for the current system (see also Displaying a device 
map on page 42).

2. In the Device map, click on the device you want to delete to highlight it.

3. In the PortDirector menu, click on Tasks > Device Map Tools > Delete. Alternatively, in 
the toolbar click on the  icon.

The selected device and its associated ports are now deleted and the icon representing 
the device disappears from the Device Map display.
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Chapter 5  Adding and deleting host cards

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want to use PortDirector to add or delete host cards from 
your system.

This chapter tells you how to add or delete host cards from your system using the 
PortDirector software. Also included is the procedure for re-scanning the system for any 
devices which are present but not active.

This chapter includes the following sections;

• Adding host cards on page 51

• Deleting host cards on page 55

• Re-scanning the system on page 57

Note
This facility is only available with the Windows NT version of 
PortDirector. It is not available under Windows 2000.

Note
For information on how to physically install host cards into your PC system, see 
the manuals provided with the host card or other peripheral.
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Adding host cards

The PortDirector software allows you to add host cards to the system using a method 
dependent upon the type of host card. For PCI host cards, no user action is required as they 
are automatically loaded by the PortDirector software on start-up. To add an ISA host card, 
see Adding an ISA host card on page 51.

Adding a PCI host card

Adding an ISA host card

To add an ISA host card to the system proceed as follows;

1. In either the left or right hand view of the PortDirector window, click on the icon for the 
parent object (for example an SX device driver).
The associated host cards are now displayed.

2. In the left hand view of the PortDirector window, click on the parent device icon.

3. In the PortDirector window, either click on the Add ISA device tool bar button or click the 
right mouse button and select the Add Device menu option. Alternatively, in the 
PortDirector menu click on Tasks > Topology View > Add Device .

Note
This facility is only available with the Windows NT version of 
PortDirector. It is not available under Windows 2000.

Note
Any PCI host cards present in the system are automatically added on 
starting the PortDirector software.

Note
Before you add an ISA card to your system you must reserve ISA 
memory and interrupt level resources in the BIOS setup. See the 
manuals for your ISA cards for details.
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The Add Device Wizard - Page 1 is now displayed as shown in the next picture.

Selecting the 
address range

4. In the Add Device Wizard - Page 1, select the ISA host card you want and click on the 
Next > button.

The Add Device Wizard - Page 2 is now displayed showing a list of valid addresses that 
the operating system will allow you to use. The default host card address range is 
selected by default as shown in the next picture.

Hint
The difference between SI/IXO and SX ISA host cards is shown below;

SI/IXO host cards have rotary address switches whilst SX ISA host cards have Dual in 
line (DIL) address switches.

SX ISA Host card

DIL address switchRotary address switches

SI/XIO host card
PortDirector User guide 
Adding host cards

Page 52

Chapter 5 Adding and deleting host cards



5. If required, in the Add Device Wizard - Page 2, select the host card address you want (if 
you don’t want the default value).

6. In the Add Device Wizard - Page 2, click on the Next > button.

The Add Device Wizard - Page 3 is now displayed.

Selecting the 
operating mode

7. In the Add Device Wizard - Page 3 select the operating mode you want as shown in the 
next table (for example, Polled) then click on the Finish button.
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.

The ISA host card you have selected is now added to the system as shown in the next 
picture. 

You have now completed the procedure for adding an ISA host card.

Operating 
mode

To Select this mode, 
choose Description

Polled Polled In polled mode the driver checks the host 
card periodically for events. This mode is 
useful where the range of available IRQ 
levels is restricted.

Interrupt An IRQ level for 
example,
11

In interrupt mode the host card signals the 
driver when an event has occurred. For 
example, data received by serial port.You 
enable this mode by selecting an Interrupt 
Request Level (IRQ Level).

Note
If you choose incorrect host cards settings, for example an 
incorrect I/O address range, the new host card is displayed by 
the PortDirector software but not used by your system. 
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Deleting host cards

The PortDirector software allows you to delete host cards from the system using the same 
procedure for all host card types. That is, both PCI and ISA cards. To delete a host card from 
the system proceed as follows;

1. Ensure that the host card you want to delete is not in use by the system.
2. In the left hand view of the PortDirector window, click on the icon for the host card that you 

want to remove (for example, an SX PCI card).

3. In the PortDirector window, either click on the Remove Device tool bar button, or click the 
right mouse button and select the Remove Device menu option. Alternatively, in the 
PortDirector menu click on Tasks > Topology View > Remove Device .
A pop-up appears asking you to confirm the deletion.

4. In the pop-up, click on Yes to confirm the deletion.

Note
This facility is only available with the Windows NT version of 
PortDirector. It is not available under Windows 2000.

Note
You cannot delete devices currently in use by the system. 
For example, if you try and remove an active host card, PortDirector 
continues to display that card and its parent devices. You can only 
remove the card by making it inactive.
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The selected device is now removed from the system and the PortDirector window 
updated accordingly as shown in the next picture.
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Re-scanning the system

PortDirector device driver software automatically scans for all detectable devices (and 
specified ISA cards) when the system starts. Once running, you can remove devices from 
the system. See Deleting host cards on page 55. The Rescan facility repeats the initial 
device driver scan and allows you to re-detect any devices which may have been removed 
from the system.

You use the re-scan facility when you want to restrict the number of ports on a system, or to 
restart a host card. To re-scan a device proceed as follows;

1. In the PortDirector window, click on the parent object (for example a host card).

2. In the PortDirector window, either click on the Re-scan tool bar button or click the right 
mouse button and select the Re-Scan Devices menu option. Alternatively, in the 
PortDirector menu click on Tasks > Topology View > Re-scan All Devices .
All devices not currently in use by the selected parent device (for example, host card) are 
re-scanned into the system and the PortDirector window updated to show them.

Note
This facility is only available with the Windows NT version of 
PortDirector. It is not available under Windows 2000.

Note
ISA host cards which have been removed from the system are not detectable and must 
be re-entered. See Adding an ISA host card on page 51.
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The devices you have re-scanned are now used by the system.
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Chapter 6  Working with com ports

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want to set up the com ports on your system for use with 
the PortDirector software.

This chapter provides information about working with com ports. It includes how to select and 
access com ports, set their default parameters as well as how to monitor com port 
performance.

This chapter includes the following sections;

• Setting the default com port parameters on page 60

• Accessing com ports from third-party NT applications on page 74

• Monitoring com port performance on page 75

• Cabling information on page 78.
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Setting the default com port parameters

About com port settings in Windows NT

The windows NT operating system allows you to read com port settings from three different 
sources; Registry, Drivers and Applications. Note that the settings read from these 
sources may not be consistent.

Registry The Registry com port settings are those stored by the Windows operating system for 
general use. Note that the physical com port settings may differ from the Registry settings.

Drivers The Driver settings are the physical com port settings at a given time regardless of how they 
were created. If you run an application which uses a com port on your system, it may use 
settings other than the current driver settings.

FAST, PCI-RAS, 
UltraPort and 
Ultraport SI card 
configuration

Applications Any third party application you run on your system may impose its own com port settings on 
the system which will be different from the driver or registry settings. When the application is 
shut down the com ports may or may not revert to their previous settings depending on the 
application.

When you configure a com port using PortDirector it retrieves the registry settings by default. 
PortDirector also allows you to retrieve the Driver settings. See Restoring to current com 
port settings on page 62. The com port configuration facility in PortDirector makes both the 
Driver and Registry settings the same. That is they are synchronised.

Note
Because the UARTs used on the FAST, PCI-RAS, UltraPort card and Ultraport SI cards 
have 64 byte FIFO’s the following limitations apply when configuring these cards;
• Tx FIFO limit: 

You can set the Tx FIFO limit to between 1 and the 64

• Tx FIFO trigger level:
You can only set to 8, 16, 32, 56

• Rx FIFO trigger level:
You can only set to 8, 16, 56, 60

• FIFO flow control threshold:
This appears as a read only parameter, the value of which is set as a result of 
changing the Rx trigger level.

To set or view these parameters see Configuring SPEED drivers for applications 
requiring smaller FIFO buffers on page 67.
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Setting up com ports from within the PortDirector software

Windows communications applications specify serial settings when you open a port device 
(for example, baud rate, parity, data bits and so on). Selected applications will refer to default 
system settings, selected using the Ports applet in the Windows Control Panel.

PortDirector allows you to specify the default system settings using the following steps;

1. In the PortDirector window, display the com ports you want using the procedures 
described in Chapter 4 Displaying your system.

2. In the right hand view of the PortDirector window, click on the com port you want to select.

You can now display the default parameters for the selected com port as follows;

3. In the PortDirector window, either click on the Properties tool bar button, click the right 
mouse button and select Properties, or double click on the com port icon. Alternatively, in 
the PortDirector menu, click on Tasks > Topology View > Device Properties .
The PortDirector Port Configuration window is now displayed.

Note
For a summary of the factory default com port settings within the PortDirector software, see 
Default com port settings summary on page 72.

Note
If you are configuring a SPEED card, the option of setting FIFO buffer levels other than 
the defaults is provided (useful when developing software applications for example). 
See Configuring SPEED drivers for applications requiring smaller FIFO 
buffers on page 67 for further details.
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4. In the PortDirector Port Configuration window, select the Standard page.

5. If required, in the Standard page select the values you want for each of the general 
parameters (Port name, Baud rate, Data bits and so forth). 

6. If the com port belongs to a Ultraport SI card you can click on the Advanced button to 
bring up the Advanced Protocol Setting page as displayed on page 63.

Restoring factory 
defaults

7. If required, in the Standard page click on the Restore Defaults button to restore the 
selected com port to its factory default settings.

Restoring to 
current com port 
settings

8. If required, in the Standard page click on the Retrieve Port Defaults button to restore the 
settings of the currently active port.

Note
For normal use, it is recommended to use the default settings in the 
Expert page of the PortDirector Port Configuration window. 
PortDirector User guide 
Setting the default com port parameters

Page 62

Chapter 6 Working with com ports



Setting Advanced 
Protocol Settings

Protocol Type: The valid software switchable protocol types are EIA-232, EIA-422, EIA-485 Full 
Duplex and EIA-485 Half Duplex. Each port on the Ultraport SI are independent of each other and 
therefore you may select different protocols per serial port.
Baud Rate Multiplier: The baud rate multiplier allows the user to multiply the configured baud rate by 
1, 2, 4, 8,16 or 32, hence achieving greater speeds on the Ultraport SI serial interfaces. This is 
applicable for each protocol type selected. Baud rates for EIA-232 are upto 921.6 Kbps per serial 
port. Baud rates for EIA-422/EIA/485 are upto 3.686 Mbps per serial port.
Slew Rate Limiting: The default setting for slew rate limiting is disabled. This will allow higher baud 
rate speeds on each EIA interface port. Slew rate limiting enabled, minimizes EMI and reduces 
reflections caused by improperly terminated cables. Operation in slew rate limited mode reduces the 
amplitudes of high-frequency harmonics.
Line Termination: The line termination parameter is not changeable by the user in EIA-232 
mode. However both EIA-422 and EIA-485 modes are defaulted to disabled but can be 
enabled by the user if needed.
EIA-485 HDX Local Echo: Local echo by default is on. This parameter applies only to EIA-
485 half duplex mode. All characters will be echoed to the user and transmitted across the 
serial ports. Some EIA-485 applications require local echo to be enabled in order to montior 
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the loopback data to determine that line contention has occurred. If your application can not 
handle loopback data then local echo should be disabled.
EIA-485 TX Driver Control: The default for this field is AUTO. When AUTO is set the 
Ultraport SI will automatically detect the beginning and ending of data being transmitted in 
order to enable and disable the transmit line. When the field is set to RTS it is the host 
application’s responsibilty to enable and disable the transmit line via the RTS handshake line 
when it wants to send data.
Auto EIA-485 Bit Delay:By Default this field is set to 0 bit delay. This field is only applicable 
if you have configured EIA-485 HDX TX control to AUTO. Values for this field are 0 through 
15 bits.

9. In the PortDirector Port Configuration window, select the Expert page.

10.The Expert page is now displayed is now showing default settings for each parameter as 
shown in the next picture.

11.If required, in the expert page set the parameters you want for Flow control, Characters 
and so forth.

Note
The com port must be closed and then opened for the new parameters 
to take effect.
PortDirector User guide 
Setting the default com port parameters

Page 64

Chapter 6 Working with com ports



12.In the PortDirector Port Configuration window, select the Debug page.

The Debug page is now displayed showing default settings for each parameter (shown in 
the next picture). This page allows you to declare a defined value as a null value.

If required, in the Debug page, declare the error character as a null value.

Note
For normal use, it is recommended to use the default settings in the 
Debug page of the PortDirector Port Configuration window. 

Item Description
Error Character Specifies the value of the character used to replace bytes 

received with a parity error.
Binary Mode Always enabled for Windows NT applications.
Parity Checking Enables parity checking when checked.
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Error Replacement Inserts the defined error character in the data stream when 
an error is detected.

Abort On Error When checked, any read or write operation will abort upon 
detection of the error character.

Note
If you are configuring a SPEED card, the option of setting FIFO buffer levels other than 
the defaults is provided (useful when developing software applications for example). 
See Configuring SPEED drivers for applications requiring smaller FIFO 
buffers on page 67 for further details.

Item Description
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Configuring SPEED drivers for applications requiring smaller FIFO buffers

PortDirector allows you to tune the com port FIFO buffer on SPEED cards to suit the 
requirements of your software application.

You need to use this facility because the com ports on SPEED cards include a large FIFO 
(128 bytes). This means that for applications designed for smaller buffer sizes you may need 
to adjust the FIFO buffer parameters to avoid timing problems. 

For example, software designed for a buffer size of 32 bytes might take four times longer to 
receive data than the original design limit and cause the application to time out. 

To solve this problem, PortDirector includes a facility for adjusting the FIFO buffer timing 
parameters thus allowing you to tune the FIFO buffers to suit your software application for 
optimum performance. 

To do this proceed 
as follows;FAST, 
PCI-RAS, 
UltraPort and 
Ultraport SI card 
configuration

1. Set up your com ports using the procedures given in Setting up com ports from within 
the PortDirector software on page 61. and keep the PortDirector Port Configuration 
window open.

2. In the PortDirector Port Configuration window, click on the FIFO Settings tab to display 
the FIFO Settings page.

Note
Because the UARTs used on the FAST, PCI-RAS, UltraPort and Ultraport SI cards have 
64 byte FIFO’s the following limitations apply when configuring these cards;
• Tx FIFO limit: 

You can set the Tx FIFO limit to between 1 and the 64

• Tx FIFO trigger level:
You can only set to 8, 16, 32, 56

• Rx FIFO trigger level:
You can only set to 8, 16, 56, 60

• FIFO flow control threshold:
This appears as a read only parameter, the value of which is set as a result of 
changing the Rx trigger level.
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3. In the FIFO Settings page, set the FIFO buffer levels using the parameters detailed in the 
next table.

Hint
To restore the default settings, use the Restore Defaults button.
PortDirector User guide 
Setting the default com port parameters

Page 68

Chapter 6 Working with com ports



4. When you have set the parameters you want in all pages of the PortDirector Port 
Configuration window, click on OK to close the window and save your changes.

Parameter Description
Tx FIFO Limit Sets the overall size of the Transmit FIFO buffer.You use this 

when you want to restrict the size of the buffer in order to control 
the data flow. This is useful when your application requires you 
to send small amounts of data but needs acknowledgement 
that the data has been sent. 
For example, if your application is designed to receive 4 bytes 
at a time, a larger value of say 16 would time out.
Permitted values for a SPEED4+ card are 1 to 128.
Permitted values for FAST, PCI-RAS , UltraPort and Ultraport 
SI cards are 1 to 64.

Tx FIFO Trigger Level Sets the level at which the com port Transmit FIFO buffer is 
filled with data each time a request for more data is made.
For example, if set to 16 bytes you get 16 bytes at a time when 
driver requests data. 
Permitted values for a SPEED4+ card are 0 to 128.
Permitted values for FAST, PCI-RAS and UltraPort cards are 8, 
16, 32 and 56.

Rx FIFO Trigger Level Sets the level at which the com port Receive FIFO buffer is filled 
before the data is passed on to an application.
For example, if set to 16 bytes, 16 bytes of data are 
accumulated at a time before data is passed on to an 
application. The FIFO trigger will also time out if the level is not 
achieved within two character periods of the last byte received.
Permitted values for a SPEED4+ card are 0 to 128.
Permitted values for a FAST, PCI-RAS, Ultraport and Ultraport 
SI card are 8, 16, 56 and 60.

High Flow Control 
Threshold

Sets the level at which data flow is suspended.
If the limit is exceeded, the driver will stop collecting data.
Permitted values for a SPEED card are 0 to 128.
For FAST, PCI-RAS and UltraPort cards, value is read only, 
set automatically from FIFO trigger level.

Low Flow Control 
Threshold

Sets the level at which data flow is resumed.
If the low flow threshold is exceeded, the driver requests more 
data.Permitted values for a SPEED4+ card are 0 to 128.
For FAST, PCI-RAS and UltraPort cards, value is read only, 
set automatically from FIFO trigger level.
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Setting up com ports using the command prompt

As an alternative to using the PortDirector software, you can list the current state of a com 
port and set the Driver parameters using the command prompt (to use the PortDirector 
software, see page 61).

Listing the current settings for a com port

To list the current state of a com port proceed as follows;

1. In the Windows desktop, Open a Command Prompt window.
2. In the Command Prompt window, type mode comX (when X is the com port number) and 

then press the Enter key.

The current settings for the selected com port are now listed as shown in the next picture.

Note
This section is intended as a brief general guide only. For further information, 
see the Windows user documentation or your System Administrator. 
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Setting com port parameters

To set com port parameters using the command prompt proceed as follows;

1. In the Windows desktop, Open a Command Prompt window.

2. In the Command Prompt window, type in a command in the form of the next example then 
press the Enter key. 

.

Note
The mode command sets the Driver com port settings. See also 
page 60.

Hint
In the Command Prompt window, type mode /? to obtain a list of all 
the command line arguments supported.

MODE COM2:19200,n,8,1

Typical command showing com port 2 with a baud rate of 19200, no parity, 8 data 
bits and one stop bit.

Baud rate

Com port 2

Parity Number of data bits

Number of stop bits
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Default com port settings summary

The default com port settings for the PortDirector Port configuration window are shown in the 
next table. For further details about the parameters listed see your Windows user 
documentation;

Page Parameter Default setting

Standard
Port Name Depends on the system
Baud Rate 9600
Data Bits 8
Parity None
Stop Bits 1
Flow Control None

Advanced Protocol Type EIA-232
Baud Rate Multiplier 1x
Slew Rate Limiting Disabled
Line Termination Disabled
EIA-HDX Local Echo Enabled
EIA-485 HDX TX Control Auto
EIA-485 HDX Bit Delay 0

Expert
Flow control CTS Output Disabled

DSR Output Disabled
XON/XOFF Transmit Disabled
XON/XOFF Receive Disabled
DTR Flow Control Disabled
RTS Flow Control Disabled

Characters XON 17
XOFF 19
EOF 0
Event 0

Misc XON 17
XOFF 19
EOF 0
Event 0
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Debug
Error Character 0
Binary Mode Disabled
Error Replacement Disabled
Parity Checking Disabled
Abort On Error Disabled

Page Parameter Default setting
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Accessing com ports from third-party NT applications

Note
If your application allows you to enter the full device name, you can 
access com ports higher than COM9 using the following device string;

\\.\comx
See the user documentation for your software for further details, or 
contact your system administrator.
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Monitoring com port performance

The PortDirector software allows you to monitor the performance of one or more com ports 
and display the results in graph form. To monitor com port performance, proceed as follows;

1. In the Windows desktop, click on the Start button and select Programs > Administrative 
Tools (common) > Performance Monitor. 
The Performance Monitor window is now displayed.

Note
This section is intended as a brief general guide only. For further information, 
see the Windows user documentation or your System Administrator. 
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2. In the Performance Monitor window, click on the + toolbar button. Alternatively, in the 
Performance Monitor menu, click on Edit > Add to chart.

The Add to Chart window is now displayed (shown in the next picture).

3. In the Add to Chart window, select the parameters you want as follows;

Parameter User action required
Computer No action required, current system displayed by default.
Object Select Perle Serial Ports.
Counter Select the counter you want (for example, Bytes Received). If required, 

click on the explain button to show a definition of the currently selected 
counter.

Instance Select the com port you want to monitor. For example, COM10. 
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4. In the Add to Chart window, click on the Add button.

The Add to Chart window now closes and the Performance Monitor window displays a 
performance graph for the selected com port as shown in the next picture.

Hint
Click here 
to change 
the viewing 
scale
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Cabling information

For information about cabling for your system, please refer to the appropriate section in the user 
guide for the specific Perle product.
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Chapter 7  Quick reference

You need to read 
this chapter if you 
want to...

You need to read this chapter if you want information about the PortDirector main window, 
toolbars and menus.

This chapter provides a quick reference guide to the PortDirector software menus and tool 
bars. In addition, cross references are provided for further information about each area.

This chapter includes the following sections;

• PortDirector main window on page 80

• Tool bar on page 82

• Menu maps on page 85
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PortDirector main window

Main window under Windows NT

The main window for the PortDirector software is shown in the next picture.

Tool bar For details about tool bars see Tool bar on page 82.

Menus For information about menus see Menu maps on page 85.

Note
The main window for PortDirector depends upon the operating system 
you are using see the following for details:
• Main window under Windows NT on page 80

• Main window under Windows 2000 on page 81

Toolbar, 
see page 82.

Main menu, 
see page 85.

Left hand view

Clicking in this part 
of the window 
allows you to 
display the system 
hierarchy.
See page 33. Right hand view

Clicking in this part of the window allows you to 
display system components
See page 37.
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Main window under Windows 2000

The main window for the PortDirector software is shown in the next picture.

Tool bar For details about tool bars see Windows 2000 toolbar on page 84.

Menus For information about menus see Menu maps on page 85.

Toolbar, 
see page 84.

Main menu, 
see page 85.

Left hand view

Clicking in this part 
of the window 
allows you to 
display the system 
hierarchy.
See page 33.

Right hand view

Clicking in this part of the window allows you to 
display system components
See page 37.

Click a button on the 
Views toolbar here 
to display Port 
Topology view or 
Device Map view.
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Tool bar

Note
The toolbar displayed within PortDirector depends upon the operating 
system you are using see the following for details:
• Main window under Windows NT on page 80

• Main window under Windows 2000 on page 81
PortDirector User guide 
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Windows NT toolbar

The functions provided by the tool bar in the main PortDirector window under Windows NT 
are summarised in the next picture. For the corresponding menu options, see Main menu on 
page 85, Right hand view menu on page 89 and Left hand view menu on page 90.

Refresh, see page 89.

Pinouts, see page 37.

Details, see page 37.

List, see page 37.

Small icons, see page 37.

Large icons, see page 37.

About this software, see page 85.

Print preview, see page 36.

Print, see page 36.

Customise toolbar, see page 85.

Toggle status bar, see page 85.

Views window, see page 85.

Properties, see page 61.

Add ISA device, see page 51.

Remove device, see page 55.

Update device, see page 26.

Re-scan, see page 57.
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Windows 2000 toolbar

The functions provided by the tool bar in the main PortDirector window under Windows 2000 
are summarised in the next picture. For the corresponding menu options, see Main menu on 
page 85, Right hand view menu on page 89 and Left hand view menu on page 90

.

Refresh, see page 89.

Pinouts, see page 37.

Details, see page 37.

List, see page 37.

Small icons, see page 37.

Large icons, see page 37.

About this software, see page 85.

Print preview, see page 36.

Print, see page 36.

Customise toolbar, see page 85.

Toggle status bar, see page 85.

Views window, see page 85.

Refresh, see page 51.

Identity, see page 44.

Adopt, see page 45.

Reboot, see page 47.

Zombie, see page 48.

Delete. see page 49. 

Properties, see page 61.
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Menu maps

This section provides menu maps for all menus available within the PortDirector software. 
See the following;

• Main menu on page 85

• Right hand view menu on page 89

• Left hand view menu on page 90.

Main menu

The main PortDirector menus are as follows:
• File menu on page 85

• View menu on page 86

• Tasks menu on page 87

• Help menu on page 88

File menu

Menu option Description
File > Print Prints the system hierarchy.

See page 36
Print Preview Previews the system hierarchy to be printed.

See page 36
Print Setup Sets up printing parameters.

See page 36
Exit Closes the PortDirector software.

See page 31.
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View menu

Menu option Description
View > Large Icons Displays the current system components as 

large icons in the right hand view of the 
PortDirector window.
See page 37.

Small Icons Displays the current system components as 
small icons in the right hand view of the 
PortDirector window.
See page 37.

List View Displays a list of the current system 
components as icons in the right hand view of 
the PortDirector window.
See page 37.

Details View Displays a detailed list of the current system 
components as icons in the right hand view of 
the PortDirector window.
See page 37.

Pinouts Displays the connector pinouts of the current 
system components in the right hand view of 
the PortDirector window.
See page 37.

Refresh Refreshes the right hand view display.
Views Window Displays the Views window
Status Bar Hides or displays (toggle) the status bar.
PortDirector User guide 
Menu maps

Page 86

Chapter 7 Quick reference



Tasks menu

Menu option Description
Tasks > Customise Allows generic Windows toolbar 

customisation.
See Windows user documentation.

Topology View > Add Device Adds a device to your system. For example, an 
ISA host card.
See page 51.

Remove Device Deletes a device from your system. For 
example an ISA host card.
See page 55.

Update Device Updates an existing device driver.
See page 26.

Re-scan All Devices Re-scans the system for any devices not 
currently in use by the device drivers.
See page 57.

Device Properties Displays the properties of the currently 
selected com port.
See page 61.

Device Map Tools >
Note that this menu 
option is only 
available under 
Windows 2000.

Identify Displays the identity of the selected RTA and 
flashes the LEDs on the actual device.
See page 44.

Adopt Allows you to adopt defined ports from 
disconnected devices.
See page 45.

Reboot Re-boots the selected RTA.
See page 47.

Zombie Disconnects the selected RTA from the system 
without physically unplugging it.
See page 48.

Delete Permanently deletes the selected device and 
its associated ports from the system. 
See page 49.
PortDirector User guide 
Menu maps

Page 87

Chapter 7 Quick reference



Help menu

Menu option Description
Help > About Displays information on this release of the 

PortDirector software.
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Right hand view menu

You display this menu as follows:
• Place the mouse cursor in the right hand view of the PortDirector window and then click 

on the right mouse button.

The right hand view menu is now displayed. This menu is described in the next table.

Menu option Description
Large Icons Displays the current system components as large icons in 

the right hand view of the PortDirector window.
See page 37.

Small Icons Displays the current system components as small icons in 
the right hand view of the PortDirector window.
See page 37.

List Displays a list of the current system components as icons in 
the right hand view of the PortDirector window.
See page 37.

Details Displays a detailed list of the current system components as 
icons in the right hand view of the PortDirector window.
See page 37.

Pinouts Displays the connector pinouts of the current system 
components in the right hand view of the PortDirector 
window.
See page 37.

Add Device Adds a device to your system. For example, an ISA host 
card.
See page 51.

Remove Device Deletes a device from your system. For example an ISA 
host card.
See page 55.

Update Device Update an existing device driver.
See page 26.

Re-scan All Devices Re-scans the system for any devices not currently in 
use by the device drivers.
See page 57.

Refresh Refreshes the right hand view display.
Properties Displays the properties of the currently selected com port.

See page 61.
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Left hand view menu

You display this menu as follows:
• Place the mouse cursor in the left hand view of the PortDirector window and then click on 

the right mouse button.

The left hand view menu is now displayed. This menu is described in the next table.

Menu option Description
Add Device Adds a device to your system. For example an ISA host 

card.
See page 51.

Remove Device Deletes a device from your system. For example an ISA 
host card.
See page 55.

Update Device Updates an existing device driver.
See page 26.

Re-scan Devices Re-scans the system for any devices not currently 
in use by the device drivers.
See page 57.

Refresh Refreshes the right hand view display.
Properties Displays the properties of the currently selected com 

port.
See page 61.
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Appendix A Contacting Perle

You need to read 
this appendix if you 
want to...

You need to read this appendix if you want to contact Perle for technical support or any other 
queries about this product.

This appendix includes the following sections;

• Making a technical support query on page 91

• Repair procedure on page 94

• Feedback about this manual on page 95

• Perle support centres worldwide on page 96

Internet access

Email

Making a technical support query

This section contains the following information about making a query;
• Who to contact on page 91

• Information needed when making a query on page 92

• Making a support query via the Perle web page on page 93

Who to contact

If you bought your product from a registered Perle supplier, you must contact their Technical 
Support department; they are qualified to deal with your problem.

If you are a registered Perle supplier, and bought your product from Perle, contact Perle 
Technical Support at the offices listed below.

Click here to access the our website at 
the following URL: 
http://www.perle.com 

Click here to email Perle at the following address;
Email: support@perle.com 
  
Making a technical support query
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Information needed when making a query

When you make a technical support enquiry please have the following information ready;

Hint
Print out this page and fill in the table provided with the basic 
information you need.

Item Write details here
Product name and version

Problem description

Operating system version
Driver version
Details of any other cards 
installed in your system

Your name
Company Name
Country
Phone number
Fax number
Email address (if available)
  
Making a technical support query
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Making a support query via the Perle web page

If you have an internet connection, please send details of your problem to Technical Support 
using the email links provided on the Perle web site in the ‘Support’ area.

See also Perle support centres worldwide on page 96 for email links and other contact 
details for the Perle technical support centres.

Click here to access our website at the following URL:
http://www.perle.com
  
Making a technical support query
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Repair procedure

Before sending a unit for repair, you must contact your Perle supplier. If, however, you 
bought your product directly from Perle you can contact directly. See Perle support centres 
worldwide on page 96 for contact information.

Customers who are In Europe, Africa or Middle East can submit repair details via a website 
form shown in the next picture. This form is on the Perle website, www.perle.com, in the 
Support area.

In the USA and Asia contact the office shown in the Technical Support section.

Website RMA (Return Material Authorisation) Form

Click here to access our web site at the following URL:
http://www.perle.com/support/rma_form.html 
  
Repair procedure
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Feedback about this manual

If you have any comments or suggestions for improving this manual please email Perle using 
the following address;

docfeedback@perle.com

Please include the title, part number and date of the manual (you can find these on the title 
page at the front of this manual).
  
Feedback about this manual
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Perle support centres worldwide

Note
Perle offers free technical support to Perle Authorised Distributors and Registered Perle 
Resellers. 
To access technical support please visit the Perle website at www.perle.com/support.
If you are unable to find the information you require, please feel free to contact our technical 
support teams by email using the addresses shown in the next table.

Country Address Email
North America Perle Systems Ltd.

60 Renfrew Drive
Markham
Ontario
Canada
L3R OE1

Email: ptac@perle.com 

Europe Perle Systems Europe Ltd. 
3 Wintersells Road 
Byfleet Surrey
KT14 7LF
UK

Email: ptac@perle.com 

Asia Perle Asia Pacific (Pte) Ltd.
190 Middle Road
#19-05 Fortune Centre
Singapore 188979

Email: ptac@perle.com

Worldwide Perle Systems Ltd.
60 Renfrew Drive
Markham
Ontario
Canada
L3R OE1

Email: ptac@perle.com 
  
Perle support centres worldwide
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